Home/Support/Support Forum/How do I get RealPort working on ConnectPort X2D?
Welcome to Digi Forum, where you can ask questions and receive answers from other members of the community.

How do I get RealPort working on ConnectPort X2D?

0 votes
I have set up a ConnectPort X2D and have the latest POST and EOS firmwares installed.

The X2D has a RealPort option in the network settings, and the release notes for this version of the firmware says that it supports simultaneous use of Python and RealPort.

I installed RealPort on my PC and set it to COM2, but when I try to connect via X-CTU (or other apps that can open COM2), the connection fails and I get these messages in the ConnectPort's event logs:

2014-11-25 17:56:10 netcx Server 0: realport connection from '192.168.1.150'.
2014-11-25 17:56:10 netcx Server 0: Open serial 1.
2014-11-25 17:56:10 netcx Server 0: Open serial 1: failed.
2014-11-25 17:56:10 netcx Server 0: Open serial 1.
2014-11-25 17:56:10 netcx Server 0: Open serial 1: failed.
2014-11-25 17:56:10 netcx Server 0: Open serial 1.
2014-11-25 17:56:10 netcx Server 0: Open serial 1: failed.
2014-11-25 17:56:10 netcx Server 0: Open serial 1.
2014-11-25 17:56:10 netcx Server 0: Open serial 1: failed.
2014-11-25 17:56:10 netcx Server 0: Open serial 1.
2014-11-25 17:56:10 netcx Server 0: Open serial 1: failed.
2014-11-25 17:56:12 netcx Closing server 0.

What am I doing wrong?

When I go to Device Operations in for the embedded XBee module, I can click Identify Device and the lights on the gateway blink 5 times, as expected.

I'm running RealPort on Windows 7, but I don't think that matters. The problem seems to be with the ConnectPort.

Versions:

POST = 1.1.3 (release_82002548_B)
Firmware = 2.17.1.0 (82002549_F1)
XBee module firmware = 0x21a7
asked Nov 26, 2014 in Realport by courtarro New to the Community (2 points)

Please log in or register to answer this question.

1 Answer

+1 vote
 
Best answer
Go to the web interface of the device and enable the Gateway Access under Configuration > XBee Network > Gateway Access > Enable serial access to the gateway radio.

Download and install the Digi Real Port driver at the following link, http://www.digi.com/support/productdetail?pid=3037&type=drivers , select the operating system.

Connect to the COM or tty port created by the RealPort driver using 115200 baud.
answered Dec 10, 2014 by userid0 Veteran of the Digi Community (2,156 points)
selected Dec 10, 2014 by courtarro
I had not noticed that option in the settings. Thanks. It's weird that it lists it as a "legacy" option, which makes it sound scary. Also it's too bad that the ConnectPort software can't "share" serial access with the RealPort clients.
...