Home/Support/Support Forum/Low power operation

Low power operation

0 votes
Seems asserting high SLEEP_REQUEST pin doesn't sleep the module if SPI lines are enabled.

It does work when using UART only, but not with SPI ( verified by measuring current draw with mm device)

is this the normal behaviour?

Documentation says one can drive sleep and transmission with SSEL only if SLEEP_REQUEST disabled, but I actually need to have separate line to sleep the module.
asked Nov 11, 2014 in DigiMesh Proprietary Mesh Networking by reynaldomic New to the Community (4 points)

Please log in or register to answer this question.

3 Answers

0 votes
Which XBee module and firmware version are you working with?
answered Nov 11, 2014 by mvut Veteran of the Digi Community (12,831 points)
Try upgrading to version 8071.
0 votes
XBP9B-DMST-002 revB
firmware: 806A (200 kbps)

there are two firmware updates, but release notes don't say anything about it.
answered Nov 11, 2014 by reynaldomic New to the Community (4 points)
Try deasserting the slave select pin.
0 votes
I am experiencing the same problem on XBee 868LP 80K with firmware 8074.

I am using SPI, and have tried to use sleep request AND slave select (by disabling sleep request) as sleep drivers. Indeed this seems to work only for UART and not for SPI. Once SPI is started, the current draw jumps up about 20mA and doesn't come down again even when the sleep pin is driven high.

I also notice that when the UART pins are disabled from the get-go, the current draw has this 20mA offset from startup, presumably since it has immediately started up SPI because of the lack of UART.

Is there anything I can try to resolve this?

Thanks,
Helena
answered Mar 5, 2018 by helzbo New to the Community (1 point)
...