Home/Support/Support Forum/Beginner on Xbee s2 broadcast mode

Beginner on Xbee s2 broadcast mode

0 votes
Hi..I know my question might answered before. But I'm having trouble getting broadcast mode setup on my 2 xbees. I've been struggling with it the whole day :(.
What I have working so far.
Coordinator: Router:
Pan ID: 2001 2001
DH : 13A200 13A200
DL : 408B916E 408B9174

The above configuration works fine for Coordinator <->Router communication.
As I understand for broadcasting mode
Coordinator DL=FFFF and Router DL = 0
But I was not successful.
I'm planning to add at least 8 xbee as Routers(with arduinos) that will Send information to Coordinator and after processing data, Coordinator will send back to all Routers. And I think in broadcast mode I don't have to specify(DL=0) for Router and Coordinator should be(DL=FFFF).
I appreciate any input that will clarify some issues I'm having. And if it's not too much, can you give the ideal configuration for my application in mind.

Thank you in advance
asked Aug 25, 2014 in RF Solutions and XBee by tacbanon New to the Community (1 point)
edited Aug 23, 2014 by tacbanon

Please log in or register to answer this question.

3 Answers

0 votes
You will have to set DH of both router and coordinator to 0 .
answered Aug 25, 2014 by vibhordabas New to the Community (1 point)
0 votes
The modules default configuration will place the radios in the configuration you are looking for. That is the Coordinator will be in Broadcast mode (DH 0, DLFFFF) and all of the routers in Unucast mode back to the Coordinator.
answered Aug 25, 2014 by mvut Veteran of the Digi Community (12,004 points)
0 votes
@ vibhordabas
@mvut
Thank you... for the time answering my post...and pointing out in right direction. I will try it out as soon as possible.
answered Aug 25, 2014 by tacbanon New to the Community (1 point)
...