Home/Support/Support Forum/AnywhereUSB printer support issues.
Welcome to Digi Forum, where you can ask questions and receive answers from other members of the community.

AnywhereUSB printer support issues.

0 votes
Trying to get a HP CP3505x printer to function on an AnywhereUSB/2 also tried it on a AnywhereUSB/5 and AnywhereUSB/14 and get the same results for all three.

Windows will install the printer after the AnywhereUSB is connected, after the printer is installed data keeps getting sent to the printer with no interaction from a user and is interpreted as a smiley face by the printer.
Eliminating the AnywhereUSB and plugging the printer in directly resolves the issue. Sending a request for a print test sheet or anything to print to the computer just gets an Error.

Also attempted it with an HP CM6040f MFP and got the same results.

Printers are listed under the supported devices section of the AnywhereUSB line. How do I get the printers to function?
Printers are listed under the supported devices
asked Apr 11, 2014 in USB Serial by Jason Sutherland New to the Community (0 points)

Please log in or register to answer this question.

3 Answers

0 votes
Have you verified the the correct services are turned on. like the lpd service. I think it might be off by default.
#> set service
Service Configuration :
index state ipport keepalive nodelay dlyd-ack service
1 off 7 off off 200 TCP Echo Service
2 off 7 na na 200 UDP Echo Service
3 on 22 off off 200 SSH Service
4 on 23 off off 200 Telnet Service
16 on 80 na na 200 HTTP Service
17 on 161 na na 200 SNMP Service
5 on 443 na na 200 HTTPS Service
19 off 513 off off 200 Rlogin Service
20 off 514 off off 200 Rsh Service
13 off 515 off off 200 Line Printer Daemon
12 on 771 off na 200 RealPort Service
answered Apr 15, 2014 by Campbell Veteran of the Digi Community (552 points)
I tried installing the LPD service in Windows 7 to see if that would help and I'm still getting the same results. The AnywhereUSB is sending unrecognized data to the printer even before I try to print anything.
0 votes
I'm not an expert on this product but these are the things to check.
-AnywhereUSB driver installed
-Make sure you have latest firmware running on your AnywhereUSB
Check baud rate on device and pc.

You can get information for this at Digi's website, and also take a look at the Digi Connect Family Command Reference Guide for help.


The set service port ON for lpd, was on the AnywhereUSB itself. You can find this info on the Command Reference above.
answered Apr 15, 2014 by Campbell Veteran of the Digi Community (552 points)
AnywhereUSB enables a virtual ... dongle, usb key, usb hard drive, ipod, smartcard reader, finger print reader, DVD burner It's a known issue with a version of our drivers. contact our suport center
<a href="https://lenovosupport.net">lenovo support</a>rt.net This is a very good product simply install usb device is never disconnect run with all usb device that I have test (mouse, keyboard, security dongle, usb key, usb hard drive, ipod, smartcard reader, finger print reader, DVD burner
0 votes
This is a common problem with AnywhereUSB printer. You may drivers and uninstalling the system then set it by default.
answered Jun 26, 2018 by TannaLDietrich New to the Community (1 point)