Home/Support/Support Forum/About two compilers.
Welcome to Digi Forum, where you can ask questions and receive answers from other members of the community.

About two compilers.

0 votes
There are two compilers in DigiEL.
arm-cortex_a8-linux-gnueabi / arm-unknown-linux-gnueabi
What is the difference?
Which way should I use?

It is my environment.

Windows7 > VMware > ubuntu12.04

Digi ESP for Embedded Linux
Version: 2.0 for Digi Embedded Linux 5.9.2.1
Build id: 20120709 DEL-5.9.2.1

platform: Wi-i.MX53
asked Apr 2, 2014 in Linux by chung New to the Community (37 points)

Please log in or register to answer this question.

4 Answers

+1 vote
Digi provided Digi ESP for Embedded Linux which will select the cross compiler gcc tool depending on the platform.

ESP for 5.9.2 has support for ConnectCore Wi-i.mx53, ConnectCore Wi-i.mx51 and ConnectCard Wi-i.mx28.

i.mx53 and i.mx51 are Cortex A8 architectures , and so it will use arm-cortex_a8-linux-gnueabi
answered Apr 3, 2014 by tuxembb Veteran of the Digi Community (288 points)
+1 vote
BTW, i just noticed that you have 5.9.2 which is real old and you cannot upgrade to latest pathces.

Download 5.9.3 from http://ftp1.digi.com/support/documentation/CC_i.MX53_Updates.htm and run package manager to upgrade to 5.9.6.2 which is the latest now.

Remember you cannot upgrade to 5.9.6.2 from 5.9.2 .
We need to have 5.9.3 to upgrade to 5.9.6.2.
answered Apr 3, 2014 by tuxembb Veteran of the Digi Community (288 points)
0 votes
Thank you.
I use arm-cortex_a8-linux-gnueabi.

and

Must I download Digi Embedded Linux (DEL) 5.9.3 Live DVD?
Must I make DVD in this?
answered Apr 3, 2014 by chung New to the Community (37 points)
0 votes
I upgraded to 5.9.6.2.

Thank you.
answered Apr 7, 2014 by chung New to the Community (37 points)
...