Home/Support/Support Forum/AWS not posting all data since latest update
Welcome to Digi Forum, where you can ask questions and receive answers from other members of the community.

AWS not posting all data since latest update

0 votes
Using Net+O/S 7.5.2.2 to latest modification level, running on Connectcore 9215.

I have a web page using AWS which has worked for years - it uses a little Javascript to update two hidden fields, and the form is then submitted to pass these values.
Since the latest update (to V1.02 of AWS package) this process fails, at least using a recent version of Firefox (V26, V27). According to Firebug the POST values are being sent correctly; however AWS only sees one of the values (the second field defined in the HTML is a zero length string).

Interestingly, the page still works with Opera 11 and 12 (but not with Firefox V13).

Has anyone else seen anything like this?
asked Feb 24, 2014 in Embedded Devices by steved2 Seasoned Professional (151 points)

Please log in or register to answer this question.

2 Answers

0 votes
Have you tried other browsers such as IE, Safari, chrome? IF so what are the results.
answered Feb 24, 2014 by dakotas_dad Veteran of the Digi Community (694 points)
Don't have any of these to hand - used to the idea that Firefox 'just works'!

Have discovered a couple of things:
1. It appears that only the first 'POST' parameter is actioned by AWS - others are totally ignored (I had two parameters, added a third)
2. Reverting to the 1.01 libraries fixes the problem.

Firebug implies that the browser sends the parameter list using '&' separators, thus:
currentFile=CONFIG_32_VRPC.TXT&updateAction1=lOAdCoNFig&zuluAction1=
Having read the description of the 1.02 update, it says "Added a Null terminator to referer header when it sees any special characters". I wonder whether either the scope of this is larger than it should be, or whether '&' in the parameter list is being replaced with a Null, truncating the list.
0 votes
For information, the most recent AWS update (V1.03) fixes this problem.
answered Mar 3, 2014 by steved2 Seasoned Professional (151 points)
...