Home/Support/Support Forum/AWS, Checkbox not reset to 0 when used in multipart/form-data (case 41637)
Welcome to Digi Forum, where you can ask questions and receive answers from other members of the community.

AWS, Checkbox not reset to 0 when used in multipart/form-data (case 41637)

0 votes
Hello,

It seems the AWS_and_Email_Updates_752 version 1.01 still have the checkbox not reset to 0 when used in multipart/form-data problem. (case 41637).

I do have all the latest packages including AWS_and_Email_Updates_752 version 1.01 and I use a checkbox in a multipart/form-data.
Every time I click upload, the set function of the checkbox is always called.

Is this problem come back with the version 1.01?

Thanks,

Seb
asked Jan 23, 2014 in NET+OS by SebB New to the Community (30 points)

Please log in or register to answer this question.

2 Answers

0 votes
Hello

I answered the other related forum entry. I just created a quick AWS application under ESP. I followed ppatierno's code the only change being that I added a submit button.

When I click on the checkbox and hit submit, it stays checked through the set call and the get call. When I click on the checkbox again to uncheck it, it stays unchecked through the set and the get.

So unless I am missing something it appears to be working correctly.

I ensured that I was up to date with all package manager patches.
answered Jan 23, 2014 by dakotas_dad Veteran of the Digi Community (694 points)
0 votes
Thanks for the answer and for your test.

I'll investigate why the set function is always called on my unit.

I'll let know the result.

Seb
answered Jan 24, 2014 by SebB New to the Community (30 points)
...