Home/Support/Support Forum/problem in sleep and packetization of xbee s2

problem in sleep and packetization of xbee s2

0 votes
Hi,

I am having some trouble dealing with xbee s2 sleep mode. Hope you all can give me some help.

The following is my setup:
The network composes of one coordinator and several end devices, all in transparent mode The coordinator is connected to X-CTU and a computer and receives all the messages.

End devices are connected to another MCU(MSP430), MCU wakes up xbee periodically(8 seconds, 16 seconds, 48 seconds etc), writes a short message (11 bytes) to xbee through UART, then immediately asserts sleep_rq pin of xbee.

Here is the problem:
if I set the wakeup interval at 8 seconds, then all messages from the same end device will come in two messages batch at roughly 16 seconds interval instead of one message every 8 seconds.
If I set the wakeup interval at 48 seconds, then again, all message still tend come in two messages batch roughly every 96 seconds, plus the last two bytes of the second message constantly get lost.

The SN, SP on both coordinator and end devices are set properly. The RO is at default value 3.

If I don't assert sleep_rq pin of xbee and keep xbee awake all the time, then no matter what the interval between two messages is, all the messages come in one by one at defined interval.

I believe this has something to do with packetization but I could figure out the exact problem.

This is driving me crazy. Some one please direct me to some relevant literature.

Thanks in advance,
Jerome
asked Jan 13, 2014 in ZigBee PRO Featureset (and legacy ZNet 2.5) by Jerome New to the Community (5 points)

Please log in or register to answer this question.

2 Answers

0 votes
Jerome, that is most likely the result of the PO or Poll Rate command. The PO command controls how often end the end device talks to its parent node.
answered May 12, 2014 by mvut Veteran of the Digi Community (12,004 points)
0 votes
Hi mvut,

thanks for your reply. I think I may have overlooked the PO command. Are you referring to the PO setup on end devices or their parents ( coordinator/router)?

I think I simply left the PO settings at default on both end devices and their parents. What would be a suitable number of PO if I want to send message to coordinator from end devices every 1 or 5 minutes?

Regards,
ZL
answered May 12, 2014 by Jerome New to the Community (5 points)
...