Home/Support/Support Forum/XBee stops responding to ATCommand Frames

XBee stops responding to ATCommand Frames

0 votes
Hi Guys,

I have an XBee 24 Series 1 and I'm trying to use it in .Net Micro Framework (on Netduino Plus) using an Arduino Wireless Shield.

It works beautifully until about the sixth or seventh command that I send to the module in API mode through the serial port, then it doesn't respond. If I ignore that lack of response and continue to send commands, it works again for an arbitrary number of commands and stops again.

My serial port is set up for 9600, No Parity, One Stop Bit, and 8 Data Bits.

I do not send and receive simultaneously. I have also tried flushing the port after every send and receive. And I've tried waiting 5 seconds after every command. These things didn't work.

It seems to not be related to the type of commands I send.

Any advice will be greatly appreciated.
asked Jan 13, 2014 in IEEE 802.15.4 by Andre.Trollip New to the Community (0 points)

Please log in or register to answer this question.

1 Answer

0 votes
Are you able to reproduce the issue by connecting the radio to a good interface board and the PC with XCTU?
answered May 12, 2014 by mvut Veteran of the Digi Community (11,300 points)
...