Home/Support/Support Forum/Newbie bringing up NET+OS 7.5 and ME 9210, and sample app doesn't run.
Welcome to Digi Forum, where you can ask questions and receive answers from other members of the community.

Newbie bringing up NET+OS 7.5 and ME 9210, and sample app doesn't run.

0 votes
After building and debugging the FTP Server File System sample application,
(1) SEGGER indicates GDB=Waiting for connection (red),
(2) Console says several "Undefined command:",
(3) Debug view says "<terminated, exit value: 0>...".

Any ideas? I'd guess the problem is starting with #1, but I can't find how to configure the connection (for localhost, for example).

Thanks!
Ed
asked May 15, 2013 in NET+OS by eingber New to the Community (2 points)
I am having a similar issue. I haven't used the Digi-JLink in years but have an app that keeps resetting so I bought another connectme 9210 with jtag. I installed the Segger drivers and can compile and the gdb server starts and connects to the target and goes through the motions of uploading firmware but when I try and run it, I always get an error reading address 0xfffffffff and it will never step or run. I see references to script files and have looked at them but do not know if DigiESP / Eclipse is looking at the scripts. I even created a .gdbinit file and added the ns9215, connectme9210, threads and treck file contents to them (found the info somewhere). The debug files and scripts are in the netOS directory but does not look like DigiESP is using them? This is with Netos 7.5.2 on a clean install and all updates done.

Please log in or register to answer this question.

10 Answers

0 votes
Hello,
Make sure that after you install the Netos 7.5 cd, you have also installed all the packages using Package Manager. Then run the Netos sample application and build for the Connect ME 9210 Platform. Once this has build successfully, connect your jtag and power up the board, run the debugger. Please see Netos Users Guide section on DigiESP.
answered May 15, 2013 by Campbell Veteran of the Digi Community (840 points)
0 votes
See section 2.4.1 starting the debugger in the DigiESP help section of the User's Guide.
answered May 15, 2013 by Campbell Veteran of the Digi Community (840 points)
0 votes
Hello

The jlink debugger daemon should have 3 "lights" towards the top adn near the middle. They are entitled (from top down) GDB, JLink and Target. Before you download through (I'll assume) ESP the bottom two (Jlink and Target) should be green adn GDB should be red. If all three are red, then you'll need to solve that first.

AS a first pass you'll want to ensure that one end of the ribbon cable (the JTAG connector) is securely connected to the jlink. The other end of the ribbon cable must be securely connected to the JTAG connector of the application board. Also you must ensure that the "polarity" of the ribbon cable is correct. I know the jlknk connector is "keyed". Also most but not all development boards have a "keyed" connector. Also (goes without saying) ensure the board is powered up.
answered May 15, 2013 by dakotas_dad Veteran of the Digi Community (694 points)
0 votes
Campbell, dakotas_dad, thanks very much for your suggestions. I even tried sequencing like you indicated - build, then connect jtag, then power up board, then run debugger. Got the "Reset device settings" dialog box and all.

Problem is that GDB isn't connecting - says "Waiting for connection", red. J-Link says "Connected" green, and Target says "ARM9, ..." green, "3.29V" green.

How does GDB server know what IP address to use? Would like 127.0.0.1 / localhost, but that doesn't seem to be happening automatically.

I've tried on two systems - a Windows 8 VM on my Mac Pro, and on Windows 8 native on a Dell laptop.

Probably something simple but elusive.

Thanks!
Ed
answered May 16, 2013 by eingber New to the Community (2 points)
0 votes
Hello,
Try looking at our 2 help sections of the Digi ESP below: This could help with troubleshooting why your jtag is not connecting. Hope this helps :)

2.5.2. J-Link GDB Server Window

2.5.4. Corrupted Flash
Cause: If you're having difficulty getting the JTAG debugger to communicate to your device, this might be due to the processor entering a bad state because it is executing corrupt code from flash.
answered May 16, 2013 by Campbell Veteran of the Digi Community (840 points)
0 votes
Hello Ed,
This forum does not allow to put screenshots, so i've uploaded a graphical version of the below post to my dropbox account:


Pdf file with screenshots and instructions


please perform few tests and report the results:
1) close DigiESP and run C:\PROGRA~2\SEGGER\JLINKA~1\JLink.exe
or go here C:\Program Files (x86)\SEGGER\JLinkARM_V408l
and doubleclik on JLink.exe
you should see black screen with something like this in the end:
SEGGER J-Link Commander V4.08l ('?' for help)
Compiled Sep 17 2009 09:42:18
DLL version V4.08l, compiled Sep 17 2009 09:41:55
Firmware: J-Link compiled Jul 30 2008 11:24:37 ARM Rev.5
Hardware: V5.40
S/N : 35400008
OEM : DIGI-LINK
Feature(s) : GDB
VTarget = 3.242V
Info: TotalIRLen = 4, IRPrint = 0x01
Info: CP15.0.0: 0x41069265: ARM, Architecure 5TEJ
Info: CP15.0.1: 0x1D0D20D2: ICache: 4kB (4*32*32), DCache: 4kB (4*32*32)
Info: Cache type: Separate, Write-back, Format C (WT supported)
Found 1 JTAG device, Total IRLen = 4:
#0 Id: 0x27926031, IRLen: 4, IRPrint: 0x0 ARM926EJ-S Core
Found ARM with core Id 0x27926031 (ARM9)
RTCK reaction time is approx. 126ns
Using adaptive clocking instead of fixed JTAG speed.
J-Link>

If it does not find a target you have a problem with a driver for Segger.
You can now close the black command window.
2) run JLinkGDBServer.exe from the same folder as above.
You should see this window:


Next go to Start MenuProgramsDigiDigi NET+OS 7.5GNU Tools and run “Digi NET+OS 7.5 Build Environment”
New black window with bash shell will come up:


Type gdb and hit enter


Then type “target remote localhost:2331”
The window should show:

And gdb server should change to all green:



If you did get all green your segger is installed and functioning properly, otherwise you have a problem with either driver, firewall or network settings.

Altrernatively instead of gdb type gdbtk and hit enter – new window will come up like this:

Go To File Menu of that new window, select target settings and configure as below:


Click OK, then go to Run menu and select connect to target:


You should see


And your gdb server window will change to all green:



Regards,
Leonid
answered May 16, 2013 by LeonidM Veteran of the Digi Community (4,355 points)
0 votes
BTW Netos 7.5 is not officially supported on Windows 8, while I've seen it working, it is not guaranteed to do so. Is your windows 64 bit? And I would not use a VM for debugging, USB transfer to VM will introduce delays that can be critical.
answered May 16, 2013 by LeonidM Veteran of the Digi Community (4,355 points)
0 votes
Thanks for all the help. Maybe just one more round.

LeonidM, I've run the tests you suggested and posted the results with screen shots here:

https://dl.dropboxusercontent.com/u/7540058/Newbie%20bringing%20up%20NET%2BOS%207.5%20-%20DON%27T%20DELETE.pdf.

Also, running Windows 8 32-bit, and I appreciate the warning about risks using a VM.

In summary, Segger driver appears to be okay, connects properly when specifying "connect" command in gdb. But not when running the Debugger from Digi ESP.

Thanks!
Ed
answered May 20, 2013 by eingber New to the Community (2 points)
0 votes
>Is the “connection” through the JTAG cable?
Yes

>The “connection” is not through Serial Port 1, is it? (The reason I ask, I need to use
COM3 on my PC.)
It's not

Can you please upload your workspace logfile?
it's located in your workspace in foldrer called .metadata - the file name is .log
answered May 23, 2013 by LeonidM Veteran of the Digi Community (4,355 points)
0 votes
Tiết lộ kinh nghiệm dự đoán xổ số miền trung hôm nay

Cùng đọc bài viết dưới đây với chúng tôi để có thể nắm bắt được một số phương pháp soi cầu lô đề miền trung hiệu quả và chuẩn xác nhất hiện nay.

Cách dự đoán XSMT theo bạch thủ lô kép

Với phương pháp dự đoán xổ số miền bắc này, người chơi xsmt thu 4 ◀◀◀ BẤM XEM cần theo dõi bảng kết quả mở thưởng về ngày hôm trước gồm các con số nào. Nếu bạn thấy dãy số giải này về ngày hôm nay gồm các con số nào.

Nếu bạn thấy xuất hiện số đầu tiên và số cuối cùng về trong dãy số giải 7 hoặc 2 số đầu tiên giải đặc biệt trùng nhau vậy bạn chỉ cần chọn chính kép của số đó làm cầu đánh ngày sau cũng khá hiệu quả và chuẩn xác.

Ví dụ bạn thấy giải đặc biệt về dạng 223947 vậy ngày sau bạn chỉ cần lấy chính cầu lô kép 22 làm cầu lô miền trung đánh ngày sau vô cùng tỷ lệ trúng cao.

Kinh nghiệm đánh đề miền trung theo lô anh em

Thực hiện cách này, người chơi Xổ số miền Trung thứ 4 ◀◀◀ CLICK sẽ theo dõi bảng kết quả mở thưởng về kỳ quay thưởng tuần trước đó của một đài nhất định nào đó gồm các con số nào. Sau đó bạn xác định xem trong bảng này có xuất hiện cầu lô nào về 2 – 3 nháy trong bảng kết quả hay không.

Nếu có bạn chỉ cần chọn số liền trước và liền kề sau của chính số đó để làm cầu đánh những kỳ quay thưởng tiếp theo của chính đài bạn muốn tham gia dự thưởng tiếp theo.

Ví dụ nếu bạn thấy kỳ quay trước về xuất hiện lô 84 về 2 nháy, vậy bạn chỉ cần chọn cầu 83 – 85 đánh cho 2 kỳ quay thưởng tiếp theo của chính đài đó.


Cách bắt lô miền trung theo thống kê

Với phương pháp này thì đòi hỏi người chơi XSMT T4 ◀◀◀ TẠI ĐÂY phải có một khả năng quan sát và tính toán một cách nhất định thì mới có thể lựa chọn cầu đánh một cách chính xác nhất.

Thực hiện cách này, đầu tiên người chơi cần theo dõi bảng thống kê tần suất lô về trong 30 ngày theo 1 đài cố định. Nếu bạn thấy xuất hiện số lô nào đó về khoảng 3 – 4 lần trong cùng một kỳ quay thưởng và nghỉ khoảng 5 – 6 ngày lại tiếp tục về.

Vậy bạn chỉ cần chọn những cầu này đánh quanh năm của đài quay thưởng đó làm cầu đánh vô cùng hiệu quả và chắc ăn. Để đạt được hiệu quả thì bạn nên đánh khung ngày sẽ hiệu quả hơn nhiều.

Hy vọng những chia sẻ trên đây của chúng tôi có thể giúp ích cho người chơi trong quá trình chọn cầu đánh ngày sau hiệu quả. Chúc các bạn may mắn!
answered Mar 30 by hypnos97 New to the Community (1 point)
edited Apr 28 by hypnos97
...