Home/Support/Support Forum/How upload my own application in my connnectME without JTAG??
Welcome to Digi Forum, where you can ask questions and receive answers from other members of the community.

How upload my own application in my connnectME without JTAG??

0 votes
I've bought the ConnectMe without Jtag (DC-ME-01T) . But I need upload my own application (image.bin) in this ConnectMe . The DC-ME-01T already has application pre-loaded on the device But I need upload my own application.

I Opened a Windows command prompt and I put the following:

ftp <device ip address>, and press Enter

and I appeared the following message:

" ftp :connect : Numero de error desconocido"

THERE any other way to load my application in the DC-ME-01T ??

and try from the command line by putting:

telnet "device ip address"
login:root
password: dbps
boot load=host-ip-address:load-file

and I appeared the following message after several
seconds

ERROR: too many response timeouts


I NEED HELP!!!! Thank you
asked Apr 26, 2013 in NET+OS by isaac1984 New to the Community (0 points)
recategorized Sep 20, 2013 by tuxembb

Please log in or register to answer this question.

3 Answers

0 votes
It looks like the application on the ConnectME is custom firmware (Digi's error messages are in English), so I think you'll need to find whoever wrote that firmware to see if they added a way to upload an image.

Otherwise, you can try the recovery directions to see if that is implemented.

http://www.digi.com/support/kbase/kbaseresultdetl?id=843
answered Apr 29, 2013 by mcarver Community Contributor (108 points)
II read the link you attached me and I found that I can not upload my own application in  modules "-S" .Only I can load my application if my module is "-C"

I have  an DC-ME-01T-S , but now I will buy an  DC-ME-01T-C to test
Yeah, that's right. I didn't know that you were running a -S, you should update your post.
0 votes
Hello

Is your connectme module on a Digi-produced development/carrier board or is it attached to a board that you developed. The answer to this will go a long way in seeing whether or not you can "recover" the device easily w/o JTAG support.

If it is on a Digi-produced carrier board, look for a header marked MFG. IS the MFG header marked P5 or P9?
answered Apr 30, 2013 by dakotas_dad Veteran of the Digi Community (694 points)
0 votes
If you have a -S variant of the Digi Connect ME you can not load your own custom NET+OS image onto the module. You must have a -C variant of the Digi Connect Me to load your custom image. DC-ME-01T and DC-ME-01T-S modules are both considered -S modules.
answered Apr 30, 2013 by charliek Veteran of the Digi Community (408 points)
Yes!!!  I purchased a " DC-ME-01T-C" and finally I successfully upload my own application

thank you very much to all for your help
...