Home/Support/Support Forum/How to disable ACK and Java API

How to disable ACK and Java API

0 votes
Hi,

I've been working with some DM XBees and first of all I want to let you know that there is a API well documented for Java that was made for ZB but it works just fine for at least basic send and recieve / configure stuff. I haven't tried the rest.

Now I'm making a firmware for a microcontroller to use API mode 2 and I want that everytime I send a message the XBee don't respond with a Transmit Status.

I thought that setting the Transmit Options byte (16) in the TX Request frame would do but it doesn't.

Is there anyway to do that?

Firmware 804B

Thank You.
asked Sep 7, 2010 in DigiMesh Proprietary Mesh Networking by Twistx77 New to the Community (2 points)

Please log in or register to answer this question.

5 Answers

0 votes
The XBee DM and the ZigBee modules share largely the same API. Some parameters of course are different but the formats should be the same.

Setting the Frame ID byte to 0 will disable the status message, so if you wish to see the status, use a non-zero value. If the frame was incorrectly formatted the information would never be sent.
answered Sep 7, 2010 by gworle Seasoned Professional (153 points)
0 votes
Oh thanks.

I forgot aobut it.

Thank you so much.
answered Sep 7, 2010 by Twistx77 New to the Community (2 points)
0 votes
Hi Twistx77

The API you are talking about is the Andrew Rapp one at http://code.google.com/p/xbee-api/ ?

I've used it with ZB modules and it works well. I should have read this thread before posting my own one about reading analog values. For example does the ZNetRxIoSampleResponse class work with Digimesh modules?
answered Sep 9, 2010 by slicker New to the Community (7 points)
0 votes
Hi Slicker,

Yes, that's the API I was talking about.

As I said before I haven't work with all the functionality that the XBees provide like the I/O and analog ports in the XBee because I use it only to communicate to a better MCU.

So I haven't tried the ZNetRxIoSampleResponse class , I didn't know about your API until yesterday if not I would've tried.

I still have a problem with Rapp's API and is that the transmition speed is slow compared to what Digi claims this modules are capable of. Some other users of the API have agreed with me on this so if I need some more transfer speed I'll try your API.

Regards.
answered Sep 9, 2010 by Twistx77 New to the Community (2 points)
0 votes
I haven't looked much into that API but there could be a potential issue depending on how the code was written and what lines you are actually sampling. The bit-mask of the DigiMesh module and the ZigBee module are very similar, but there is a difference or two in the number of IO lines that are available. Since this could change, you may need to modify the ZigBee API slightly to handle the difference in the IO sample bit-mask. Otherwise however, they should be in the same format.
answered Sep 9, 2010 by gworle Seasoned Professional (153 points)
...