Home/Support/Support Forum/Console Debug Message
Welcome to Digi Forum, where you can ask questions and receive answers from other members of the community.

Console Debug Message

0 votes
I have update our BSP to version 2.2.2 from 2.0.x. Now, for using the debug console for kernel messages we need to set 2 environment variables in the UBOOT.

1- setenv silent no
2- setenv console console=com2,38400
3- saveenv

I have done this on two difference CC9M2443 modules. The messages are showing only on one of the 2.

Do have I to do something else when we were using another bsp before?

Do we require another version of the UBOOT? I am running a custom version based on 1.1.6 .

Thank you
asked May 4, 2012 in Windows CE by kpineau New to the Community (8 points)

Please log in or register to answer this question.

3 Answers

0 votes
I have found a workaround to fix this issue.

If the module was previously used with an older OS. You must use the JTAG port and erase completely the flash memory and then flash back everything config, firmware, uboot, etc..

Set the console variable and everything will work correctly.

The reason I didn't have this issue with my other module is that they were brand new module out of the box without any firmware on it beside u-boot.

Hope this will help out someone else ;)
answered May 15, 2012 by kpineau New to the Community (8 points)
0 votes
finally,
here is another update.

In the documentation, they said you can use the uboot environment variable "silent" to enable / disable the debug serial console.

But if you put the console in sleep mode with the command "setenv silent yes" and then reactivate it later by setting the variable to "no" the console is still disable.

The only way I can reactivate it is by doing an "envreset" and then reset all non default variable which is not really user friendly.

Anyone find a better way to do this?

Thank you
answered May 29, 2012 by kpineau New to the Community (8 points)
0 votes
You can also reconfigure those settings from within WinCE by running the command uboot_env with the proper options (I don't remember them off hand). Once that is done, reboot the module and you should be up and running again.

~Mike
answered Jun 7, 2012 by mcarver Community Contributor (108 points)
...