Home/Support/Support Forum/FileOS example hangs
Welcome to Digi Forum, where you can ask questions and receive answers from other members of the community.

FileOS example hangs

0 votes
I have recompiled the bsp as shown in the documentation (the help file), but as soon as I turn BSP_INCLUDE_FILESYSTEM_FOR_CLIBRARY on, the programs hang after the splash screen. What am I missing?
asked Jan 8, 2004 in NET+OS by egawtry Veteran of the Digi Community (349 points)

Please log in or register to answer this question.

2 Answers

0 votes
We are indeed aware of the problem you are seeing and it had been slated to be fixed.

While I am not aware of the precise nature of the problem, it has soemthing to do with the fact that the Connect ME is shipped out of the factory with a file system already in flash.

Until a permanent fix is put into the File System API I can offer you a modified version of the NAFlash example that will erase everything in the flash, short of the BOOT and POST sectors, which are required in order for the device to properly boot and load you NET+OS application.

The file, eraseFlash.zip, can be obtained via ftp://ftp.digi.com/incoming/tech_support/ConnectME/examples/eraseFlash.zip.

I have not performed a detailed test of this application, however, it has proven to work for me without incident. If you experience problems let me know. You are certainly free to modify the program further.

Once you have successfully run 'eraseFlash' you should be able to successfully load your file system enabled example.

Regards,
Cameron
Technical Support Engineer
Digi International
answered Jan 9, 2004 by Cameron Seasoned Professional (221 points)
0 votes
That did the trick. It give a lot of errors on the run (saying that things aren't erased), but once that was run then the fileos app worked.

Thanks
-Erik
answered Jan 12, 2004 by egawtry Veteran of the Digi Community (349 points)
Is there a solution for the system hanging at startup when the file system is enabled?
...