Home/Support/Support Forum/ConnectCore 9M U Boot
Welcome to Digi Forum, where you can ask questions and receive answers from other members of the community.

ConnectCore 9M U Boot

0 votes
Hi all,

I'm using CC9m2443 board, but accidentally I deleted U Boot from the board. Now when I turn on the board nothing shown on the serial terminal. How can I overcome this situation by writing back the U boot.?

I'm having J Tag, and I'm using Windows XP / Ubuntu 10.04 LTS.

pls help me....


Alex
asked Jun 20, 2011 in Windows CE by puliveli New to the Community (6 points)
recategorized Nov 26, 2013 by tuxembb

Please log in or register to answer this question.

10 Answers

0 votes
Hi,

the recovery mechanism is explained here
http://www.digi.com/support/productdetl.jsp?pid=3640&osvid=181&tp=3&s=394&tp2=0

Recovery - http://ftp1.digi.com/support/documentation/ubootrecover.zip

This will help.
answered Jun 20, 2011 by bobthomas13 Seasoned Professional (182 points)
0 votes
Thank u for the reply... i will find th link.....
answered Jun 20, 2011 by puliveli New to the Community (6 points)
0 votes
hi bob,

for this mechanism the Uboot must be running on the board, right....??? my case u boot is deleted from the board. its not running....

any suggestions pls????
answered Jun 20, 2011 by puliveli New to the Community (6 points)
0 votes
This is used for recovering module when "UBOOT" is "LOST".

you have to follow the 4 steps explained in http://ftp1.digi.com/support/documentation/ubootrecover.zip
in order.
answered Jun 20, 2011 by bobthomas13 Seasoned Professional (182 points)
0 votes
hi Bob ,

when I run the batch file it shows "JLink is not recognized as internal or externel commnd"

what I'v to make sure before trying....???

thnks
Alex
answered Jun 21, 2011 by puliveli New to the Community (6 points)
0 votes
Hi, Make sure that S4.3 switch on.

Follow the steps,,

Turn off the development board.
Connect the power cable.
Connect the JTAG adapter to the MULTI-ICE connector X13/JTAG on the development board.
Connect the JTAG adapter to your PC via the supplied USB cable.

Launch a terminal program (e.g. HyperTerminal) with 38400 8-N-1 no flow control.
Plug the cable into Serial Port A of the Digi development board.

To allow the JTAG to write to RAM the dip switches S4 on the Digi Development board must be set:
Set S4.3(OCD) to 'On' (toward the edge of the development board ,Set all others to 'Off'

Next Power on the module.
Run the ccw9m2443js.bat file from the C:\Program Files (x86)\SEGGER\JLinkARM_V422g' directory for your module.


Erase the U-Boot section of flash with:

nand erase 0x0 0xc0000
Then write U-Boot to flash with:

nand write 0x33e00000 0x0 0xc0000
Power down the device
Unplug the JTAG
Set S4.3 to off
answered Jun 22, 2011 by cpigilam Veteran of the Digi Community (655 points)
0 votes
Hi,

thank you so much for the help...

now I recoverd the U boot, but still problem with Environment area. It shows,


NVRAM: Original Critical is BAD
NVRAM: Mirror Critical is BAD
NVRAM: Original and Mirror don't match
NVRAM: Using Mirror


also, when I try to set and save into file it shows,


CCW9M2443 # setenv ipaddr 192.168.37.17
CCW9M2443 # saveenv
Saving Environment to Digi NVRAM...
*** Error: NVE_NOT_FOUND: (U-Boot)


why UBoot is not able to accss the environment variables...???

pls help...

Alex
answered Jun 22, 2011 by puliveli New to the Community (6 points)
0 votes
Hi,

Could you please send the "flaprt" data and printenv , printenv_dynamic variables.

#intnvram printall data also
answered Jun 22, 2011 by cpigilam Veteran of the Digi Community (655 points)
0 votes
hi,

I got some clue... when I use my custom UBoot, then only it shows this error...

let me have a check for more clarity....

alex
answered Jun 22, 2011 by puliveli New to the Community (6 points)
0 votes
sorry friends,

I think i made a mistake by loading my custom bootloader into the board without making changes in NVRAM. (during this time we should not use savenv till all the upgrade finishes)

now I''m able to load my custom Uboot and Kernel..

thank you for your help and comments...

Alex
answered Jun 22, 2011 by puliveli New to the Community (6 points)
...