Home/Support/Support Forum/problem in create an new project with basic web server
Welcome to Digi Forum, where you can ask questions and receive answers from other members of the community.

problem in create an new project with basic web server

0 votes
I have completed my application in my development kit with JTAG ConnectME
where my basic application is to convert RS232 to TCP data and With the help of HTML to C,
I created a website to configure my device.

My application with the web site works by modifying the sample project HTTP SERVER SAMPLE.
This is replacing the html folder files. C by my own page or files .c .

In the data sheet evaluation kit mentions that the Primary Serial Port is available for an
application and The Secondary Serial Port is for debugging purposes, but when I work on the
project HTTP SERVER SAMPLE replacing the files. C by my own files, the port primary operates as debugging purposes and
the secondary port works as available (ports are reversed) and my application works properly.

How can I make my application work properly with my primary port?

I tried to create my application without changing the HTTP SERVER SAMPLE project. I try to create a project from the beginning
but does not work for errors of libraries

I perform the steps to create a new project are:
file -> new -> managed make C project

Thanks for you HELP!!!!!!!
asked Feb 23, 2010 in NET+OS by isaac New to the Community (8 points)
recategorized Dec 10, 2013 by tuxembb

Please log in or register to answer this question.

1 Answer

0 votes
You wiull need to disable STDIO and possibly also a dialog port in GUI or just change them in bsp_sys.h:
#define BSP_STDIO_PORT "/com/0"

* BSP_DIALOG_PORT determines whether or not the initialization code will prompt for configuration
* parameters. It should be set to a string that contains the serial port to prompt with. If it
* is not set, or if it contains an invalid port, then the initialization code will not prompt for
* configuration parameters.
* @external
* @since 7.1
#define BSP_DIALOG_PORT "/com/0"

If you want to disable them, comment them out, if you want to move them to other port, change /com/0 to /com/X where is is Whatever port you whant to change it to. Then in you application use /com/0 instead of /com/1
answered Feb 23, 2010 by LeonidM Veteran of the Digi Community (3,517 points)