Home/Support/Support Forum/DIA and dia.pyr / skip configaddress
Welcome to Digi Forum, where you can ask questions and receive answers from other members of the community.

DIA and dia.pyr / skip configaddress

0 votes
I have come across an issue that I think originates in Dia's internals.

Let's say I have several XBee ZB devices and a running ConnectPort with Dia. All devices transmit to Dia and everything is wonderful.

For some reason (mostly in my case because I have resetted one of the devices -- 4 times "ident"), one of the devices forgot its settings, but does reconnect to the Mesh.

At this point, it can be seen on ConnectPort's web page, and one can set its parameters manually.

BUT: Dia is not aware that its config is gone, so does nothing, and for some reason does not get the data.

All right, I said to myself, let's reset the ConnectPort. Alas, it shows tat said device is in the SkipConfig address list, even though my .YML lists no such device.

The only way around I found so far was to manually delete Dia-created dia.pyr and restart. Then the device got configured.

This makes me think that something in Dia saves ZB addresses somewhere in dia.pyr. And if I'm right, then I want it out. Any help appreciated!!
asked Feb 28, 2011 in Python by cmigliorini New to the Community (24 points)

Please log in or register to answer this question.

2 Answers

0 votes
Indeed it does. Please take a look at the documentation for the xbee_device_manager. https://developer.idigi.com/edocs/documentation/user/devices/xbee/xbee_device_manager.html. You'll see that it has an 'update_skiplist' setting. This currently defaults to True, which will cause Dia to only set the configuration for a node once and then add it to the skiplist.

You'll want to turn this off to get the behavior that you desire.
answered Feb 28, 2011 by DigiGuy42 Community Contributor (102 points)
0 votes
Darn it! The RTFM effect again. Thanks!
answered Feb 28, 2011 by cmigliorini New to the Community (24 points)
...