Once you set it up, your Digi Application Development Environment for Digi Embedded Yocto enables cross-platform application development for ConnectCore devices using a desktop Linux workstation with Eclipse and Digi plugins.

Before starting development for your ConnectCore platform, make sure your device is correctly connected, powered, and running. See Step 2 - Set up the hardware and Step 3 - Program the Yocto firmware.

Download and install the software

You can use either of the following methods to install the Digi Application Development Environment:

Install Digi Application Development Environment for Linux

Follow the steps below to download and install Digi Application Development Environment for Linux.

Requirements

To install Digi Application Development Environment for Linux, you need a development machine with at least:

  • Linux 64-bit system (Ubuntu 14.04 or Ubuntu 16.04)

  • 4 CPU cores

  • 4 GB of RAM

  • Free disk space:

    • Development environment: 500 MB for the development environment

    • Digi Embedded Linux toolchain: Between 3 GB and 10 GB, depending on the platform

  1. Download the installer file from: ftp://ftp1.digi.com/support/digiembeddedyocto/eclipse/eclipse-dey-2.6-r2.run.

  2. You must have write permissions in the selected installation path during the installation process. The default directory is /opt/eclipse. Use the install command to create the installation directory with write permissions:

    ~> sudo install -o <your-user> -g <your-group> -d /opt/eclipse
    You can get your primary user and group using the id command.
  3. When the download is complete, double click the eclipse-dey-2.6-r2.run file. Follow the steps in the installer Setup Wizard.

    You can also run it using the Linux terminal.

    ~> chmod +x eclipse-dey-2.6-r2.run
    ~> ./eclipse-dey-2.6-r2.run

    A Readme dialog appears when the installation is complete.

  4. By default, the installer launches an Eclipse instance.

Install Digi Embedded Yocto plug-ins from Eclipse

The Digi Application Development Environment for Linux installer includes the Eclipse IDE for C/C++ Developers. To add the Digi plugins to an existing Eclipse installation:

Requirements

To install the Digi plugins from within Eclipse, you need:

Add the Digi plugins to an existing Eclipse installation

  1. Go to Help > Install New Software. The Install wizard is displayed.

  2. Click Add. The Add Repository dialog opens.

  3. Type Digi Embedded Yocto Eclipse Plug-ins in the Name text box.

  4. Type ftp://ftp1.digi.com/support/digiembeddedyocto/eclipse/oxygen-updates in the Location text box.

  5. Click OK. The search process begins. When it finishes, the available plugins are listed in the table.

  6. Expand Digi Embedded Yocto category and select Digi Embedded Yocto Feature item.

  7. Click Next and follow the instructions in the wizard.

    A Security Warning may appear before finishing the installation. Click Install anyway to proceed.
  8. When the installation process finishes, Eclipse asks you to restart. Click Restart Now. After the restart, the Digi plugins are available.

Install and configure toolchains

The SDK provides a cross-development toolchain and libraries tailored to the contents of a specific image.

Digi provides a pre-compiled C/C++ toolchain that matches the dey-image-qt image and contains the appropriate libraries for developing against that image.

The installed toolchain consists of several files and directories: an environment setup script, some configuration files, and host and target root filesystems. For more information, see the Yocto Project Application Development and the Extensible Software Development Kit (eSDK) manual.

Install a Digi toolchain

To install new Digi Embedded Yocto toolchains in your system, follow these steps:

  1. Select Window > Preferences.

  2. Select DEY Toolchains from the list on the left.

  3. Click Browse and select the directory where you want to install the new toolchains, which must have write permissions. The default directory is /opt/dey.

  4. Click Download new toolchains. The Install new DEY toolchains dialog opens listing all the available toolchains to install.

  5. Select the toolchains you want to install and click Install selected.

    You can filter the available toolchains by platform using the platform combo box.
  6. The installation process starts and the dialog displays the installation status.

    You can stop the installation process at any time by clicking Cancel.
  7. Once the process finishes, click Back to return to the available toolchains list and continue installing new toolchains, or click Close to close the dialog.

  8. The installed toolchains table is updated with the new toolchains. Select a new default.

  9. Click Apply and Close to save the changes.

The Close button closes the dialog and stops any active and pending toolchain installation. If you click the button and the install process has not yet finished, a popup message asks for confirmation.

Install your custom toolchain

You must manually install any custom toolchains generated with Digi Embedded Yocto. To do this, follow these steps:

  1. Copy the toolchain installer script to your host machine.

  2. Give execution permission to the installer and install the toolchain on your host PC.

    ~> chmod +x dey-glibc-x86_64-dey-image-qt-xwayland-aarch64-toolchain-2.6-r2.sh
    ~> ./dey-glibc-x86_64-dey-image-qt-xwayland-aarch64-toolchain-2.6-r2.sh
    ~> chmod +x dey-glibc-x86_64-dey-image-qt-xwayland-aarch64-toolchain-2.6-r2.sh
    ~> ./dey-glibc-x86_64-dey-image-qt-xwayland-aarch64-toolchain-2.6-r2.sh

Configure installed toolchains

You can configure Digi Embedded Yocto toolchains and select a default toolchain in Eclipse preferences.

  1. In Eclipse, go to Window > Preferences.

  2. Select DEY Toolchains from the list on the left.

  3. Click Browse and navigate to the path containing the installed Digi Embedded Yocto toolchains. Eclipse looks for available toolchains in the specified path. All discovered toolchains are listed in the table.

    Click Search to perform a new toolchain search in the selected directory.
  4. Select a default toolchain to use.

  5. Click Apply and Close to save the changes.

If DEY toolchain settings are not properly configured on Eclipse startup, a popup dialog is displayed asking you to configure them.

Connect to a remote machine from terminal

Eclipse includes a Terminal view plugin that allows you to connect to a remote machine from within Eclipse. This feature supports multiple connection types including SSH and serial. You can establish these connections within any of the Eclipse perspectives.

Open Terminal view

To open Eclipse Terminal view, follow these steps:

  1. Click Window > Show View > Other.

  2. Select Terminal > Terminal and click Open.

  3. The Terminal view is displayed within the Eclipse active perspective.

Establish a terminal connection

To establish a terminal connection, follow these steps:

  1. Click the Open a Terminal button within the Terminal view. The Launch Terminal dialog appears.

  2. Select the Connection Type:

  3. Configure the specific connection type settings and click OK.

  4. After establishing a connection, the Terminal view is connected to a shell on the remote system. You may enter commands directly in the Terminal view window in Eclipse.

  5. Use the toolbar buttons to perform common actions such as copy, paste, lock scroll, clear, etc.

  6. You can disconnect the active Terminal connection using the Disconnect Terminal Connection button.

You can also create a new connection using the Open a new Terminal View button, which creates a new Terminal view instance within Eclipse.

Local terminal

The local terminal opens a shell console to execute commands in the local host computer. You must configure the Encoding setting (the character encoding format to be used by the terminal) for a local terminal connection.

SSH terminal

In SSH, or secure shell, protocol, encrypted data is exchanged between two applications over a network TCP/IP connection. You can send SSH commands to and receive output from a remote machine from the Eclipse Terminal View. Configure the following settings for an SSH connection:

  • Hosts: List of saved remote hosts. If you select a valid host, this setting configures the rest of the settings.

  • Host: Host name or IP of the remote machine to connect to.

  • User: SSH session user name.

  • Password: SSH session password.

  • Timeout: SSH session read timeout in seconds.

  • KeepAlive: Interval for sending keepalive messages in case of inactivity.

  • Port: SSH connection port.

  • Encoding: The character encoding format to be used by the terminal.

  • Save user: Check to save the user name for the next time this connection is used.

  • Save password: Check to save the password for the next time this connection is used.

Serial terminal

Serial connections transfer data over a serial cable, typically through an RS-232 port. Many products have a serial port available for accessing a login terminal and executing remote commands. Configure the following settings for a serial connection:

  • Serial port: Local host serial port path to use for the connection.

  • Baud rate: Baud rate of the serial connection.

  • Data size: Number of data bits to use in the serial communication.

  • Parity: Parity of the serial connection.

  • Stop bits: Number of stop bits to use in the serial communication.

  • Encoding: Character encoding format to be used by the terminal.

Telnet terminal

Telnet protocol transfers data and executes plain-text commands over a TCP/IP network. Configure the following settings for a Telnet connection:

  • Hosts: List of saved remote hosts. If you select a valid host, this setting configures the rest of the settings.

  • Host: Host name or IP of the remote machine to connect to.

  • Port: Telnet connection port.

  • Timeout: Telnet connection read timeout in seconds.

  • End of line: Character combination to be used as end-of-line indicator.

  • Encoding: Character encoding format to be used by the terminal.

Telnet terminal setup is similar to SSH, except the username and password are passed to the target machine in plain text form after the Telnet session has been initiated.