Requirements

To install a Digi Embedded Yocto toolchain, you need a development machine with at least:

  • Linux 64-bit system (Ubuntu 14.04 or Ubuntu 16.04)

  • 4 CPU cores

  • 4 GB of RAM

  • Between 2 GB and 10 GB of free disk space, depending on platform

Before starting development for your ConnectCore platform, make sure your device is correctly connected, powered, and running. See Step 2 - Set up the hardware and Step 3 - Program the Yocto firmware.

Download and install the toolchain

Digi Embedded Yocto provides a pre-compiled C/C++ toolchain that matches the default image artifact. You can use it to cross-compile applications to run on Digi embedded platforms, including graphical GTK or QT5 applications.

To install new Digi Embedded Yocto toolchains in your system, follow these steps:

  1. Download the toolchain installer from the Digi support page. (You can also use your own pre-compiled toolchains.)

    wget ftp://ftp1.digi.com/support/digiembeddedyocto/2.6/r2/sdk/ccimx8x-sbc-express/xwayland/dey-glibc-x86_64-dey-image-qt-xwayland-aarch64-toolchain-2.6-r2.sh
  2. Give execution permission to the installer and install the toolchain on your host PC.

    ~> chmod +x dey-glibc-x86_64-dey-image-qt-xwayland-aarch64-toolchain-2.6-r2.sh
    ~> ./dey-glibc-x86_64-dey-image-qt-xwayland-aarch64-toolchain-2.6-r2.sh

To install new Digi Embedded Yocto toolchains in your system, follow these steps:

  1. Download the toolchain installer from the Digi support page. (You can also use your own pre-compiled toolchains.)

    wget ftp://ftp1.digi.com/support/digiembeddedyocto/2.6/r2/sdk/ccimx8x-sbc-pro/xwayland/dey-glibc-x86_64-dey-image-qt-xwayland-aarch64-toolchain-2.6-r2.sh
  2. Give execution permission to the installer and install the toolchain on your host PC.

    ~> chmod +x dey-glibc-x86_64-dey-image-qt-xwayland-aarch64-toolchain-2.6-r2.sh
    ~> ./dey-glibc-x86_64-dey-image-qt-xwayland-aarch64-toolchain-2.6-r2.sh